using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]";
string substitution = @"";
string input = @"test
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}