$re = '/^-?\d*\.{0,1}\d+$/';
$str = 'Bloodseeker-0.51%55.26%188,271 ';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;