package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`sip:(\d+)@(([a-zA-Z0-9])[a-zA-Z0-9-.]+[a-zA-Z0-9])`)
var str = `sip:123@asdf.asdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}