re = /sip:(\d+)@(([a-zA-Z0-9])[a-zA-Z0-9-.]+[a-zA-Z0-9])/
str = 'sip:123@asdf.asdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end