package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span style=\\?"color:([a-zA-Z\s]*?)\\?">((.|\n)*?)<\/span>`)
var str = `<p style=\"text-align:left\">
<span style=\"color:Green\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Times New Roman\">There is some content for a mm advertisment.</span>
</span>
</span>
</p>
<p style=\"text-align:left\">
<span style=\"color:Green\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Times New Roman\">There is some content for a mm advertisment.There is some content for a mm advertismen</span>
</span>
</span>
<span style=\"color:Red\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Times New Roman\">t.There is s</span>
<span style=\"font-family:Verdana\">ome content for a mm advertisment.There is some content for a mm advertisme</span>
</span>
</span>
<span style=\"color:Green\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Verdana\">nt.There is some content for a mm adv</span>
<span style=\"font-family:Times New Roman\">ertisment.There is some content for a mm advertisment..</span>
</span>
</span>
</p>
/***************************
String tested in my script
***************************/
<p style=\"text-align:justify\">
<span style=\"font-size:12pt\">
<span style=\"color:Green\">
<span style=\"font-family:Verdana\">There is some content for a mm advertisment.There is some co</span>
<span style=\"font-family:Times New Roman\">ntent for a mm advertisment</span>
</span>
</span>
</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}