const regex = /\/\/(.*\/){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/(.*\\\/){3}', 'gm')
const str = `http://localhost:2000/machine/my-test-machine/3
http://localhost:2000/my-test-machine`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}