#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/{2,}(?:(?!\/\/).)*?$"
Local $sString = "output port_a; // comments remove this port" & @CRLF & _
"// output port_a; // comments remove this port" & @CRLF & _
"// output port_a; " & @CRLF & _
"// output port_a; // comments read/write " & @CRLF & _
"" & @CRLF & _
"// output port_a; // more // comments remove this port" & @CRLF & _
"" & @CRLF & _
"// output port_a; // more // more // more // comments remove this port"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)