use strict;
my $str = 'output port_a; // comments remove this port
// output port_a; // comments remove this port
// output port_a;
// output port_a; // comments read/write
// output port_a; // more // comments remove this port
// output port_a; // more // more // more // comments remove this port';
my $regex = qr/\/{2,}(?:(?!\/\/).)*?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";