import Foundation
let pattern = #"\/{2,}(?:(?!\/\/).)*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
output port_a; // comments remove this port
// output port_a; // comments remove this port
// output port_a;
// output port_a; // comments read/write
// output port_a; // more // comments remove this port
// output port_a; // more // more // more // comments remove this port
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)