package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)( - .*)| `)
var str = `My Beautiful Video - Hello darling - 19.10.2015 10:00`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}