using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w{8}-\w{4}-\w{4}-\w{4}-\w{12}";
string input = @"data/vms/uuid=1a874c81-9e38-4c4f-bcfa-1b52094f2c8b/flavor/ram_mib";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}