$re = '/\b\w+\[\s*([\'"])(.+?)\1\s*\]/';
$str = 'someObject[\'propertyName\']
someObject["propertyName"]
someObject[ "propertyName" ]
someObject[ \'propertyName\' ]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);