#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Phone:\s*\({0,1}(\d{3})\){0,1}\s*(\d{3})-*(\d{4})\n{0,1}"
Local $sString = "Phone: (630) 690-0336\nFax: (630) 355-0197" & @CRLF & _
"Phone: (630) 6900336\nFax: (630) 355-0197" & @CRLF & _
"Fax: (630) 355-0197\nPhone: (630) 6900336"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")