$re = '/(var\s+(\w[\w\-\_]*)\s*(?:=\s*(\d+|[\'"][\w\W]+[\'"]))?;?)/m';
$str = 'var stuff = 1;
var string = "dsa";
var lone;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);