import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?\\bWASHER\\s+FLAT\\s+10MM\\s+SS\\b.*";
final String string = "4078. F00010 WASHER FLAT 20MM GALV\n"
+ "4078. F00010 WASHER FLAT 10MM SS\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}