import Foundation
let pattern = #"[àâáãä]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
àbâbã
abábä
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"a"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)