using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-z\d]";
string substitution = @"";
string input = @"a{b}c'=%""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}