const regex = /[^a-z\d]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-z\\d]', 'g')
const str = `a{b}c'=%"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);