use strict;
my $str = 'a{b}c\'=%"';
my $regex = qr/[^a-z\d]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";