using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" - |- | -";
string input = @"[ 'WOMEN\'S CC CROPPED TOP T-SHIRT -WHITE - L' ]
[ 'WOMEN\'S CC LOW CUT RACER BACK TUNIC VEST -WHITE - M' ]
[ 'WOMEN\'S CC LOW CUT RACER BACK TUNIC VEST - WHITE -L' ]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}