// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r" - |- | -").unwrap();
let string = "[ 'WOMEN\\'S CC CROPPED TOP T-SHIRT -WHITE - L' ]
[ 'WOMEN\\'S CC LOW CUT RACER BACK TUNIC VEST -WHITE - M' ]
[ 'WOMEN\\'S CC LOW CUT RACER BACK TUNIC VEST - WHITE -L' ]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}