re = /(?<!-)\b[1-9]\d*\s+(left|remaining)/m
str = '0 left
1 left
2 left
3 left
0 remaining
1 remaining
2 remaining
you have 3 left
(13 left)
there are 12 remaining today
You have (-12 left) today
There are (3 left)
-15 remaining today
you have -24 left today'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end