#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(@\S+)\s(.+.com)"
Local $sString = "@xxx test@xxx.com"
Local $sSubst = "<a href="$1"> $2 </a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)