const regex = /((?:oxygen|nitrogen|carbon_dioxide|toxins)\ ?\=\ ?.*?[;\}])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:oxygen|nitrogen|carbon_dioxide|toxins)\\ ?\\=\\ ?.*?[;\\}])', '')
const str = `"bX" = (/obj/machinery/conveyor{dir = 2; id = "awaysyndie"},/turf/open/floor/plating{carbon_dioxide = 48.7; dir = 4; heat_capacity = 1e+006; icon_state = "warnplate"; nitrogen = 13.2; oxygen = 32.4; temperature = 251},/area/awaycontent/a4{has_gravity = 1; name = "Syndicate Outpost"})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}