$re = '/((?:oxygen|nitrogen|carbon_dioxide|toxins)\ ?\=\ ?.*?[;\}])/';
$str = '"bX" = (/obj/machinery/conveyor{dir = 2; id = "awaysyndie"},/turf/open/floor/plating{carbon_dioxide = 48.7; dir = 4; heat_capacity = 1e+006; icon_state = "warnplate"; nitrogen = 13.2; oxygen = 32.4; temperature = 251},/area/awaycontent/a4{has_gravity = 1; name = "Syndicate Outpost"})';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);