using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<html>(?:(?!<\/html>).)*<\/html\>";
string input = @"This is text
<html>
<div>
some content
</div>
</html>
This is more text
<html>
<div>
some content
</div>
</html>
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}