using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^+:?\r\n]++|\?.)+|(?<=[+:]|^)(?=[+:]|$)";
string input = @"a++b
+a
b+
a+b+c
a?+b+c
a??+b+c
a???+b+c
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}