using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(simple)(?![^<>]*>)";
string input = @"This is simple html text <span class='simple'>simple simple text text</span> text";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}