$re = '/(simple)(?![^<>]*>)/i';
$str = 'This is simple html text <span class=\'simple\'>simple simple text text</span> text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);