re = /(simple)(?![^<>]*>)/i
str = 'This is simple html text <span class=\'simple\'>simple simple text text</span> text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end