const regex = /(?:\+?91-?\d{10})|(?:0?\d{10})(\,(?:\+?91-?\d{10})|(?:0?\d{10}))*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+?91-?\\d{10})|(?:0?\\d{10})(\\,(?:\\+?91-?\\d{10})|(?:0?\\d{10}))*', 'gs')
const str = `+919883443344,+91-9883443344,919883443344,91-9883443344,09883445666,9883443344`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}