const regex = /(?: # non-capturing group
\#summertime\b # match #summertime
| # or
\G(?<!^), # a comma not at the beginning of string and match it only if it's after the last match
) # closing the non-capturing group
\s* # some optional whitespaces
\K # forget what we matched so far
[^\s,]+ # match anything that's not a whitespace nor a comma one or more times/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?: # non-capturing group
\\#summertime\\b # match #summertime
| # or
\\G(?<!^), # a comma not at the beginning of string and match it only if it\'s after the last match
) # closing the non-capturing group
\\s* # some optional whitespaces
\\K # forget what we matched so far
[^\\s,]+ # match anything that\'s not a whitespace nor a comma one or more times', 'g')
const str = `#summertime swimming, running, tanning`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}