using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(?<!\d\.)\d+(?!\.?\d)";
string input = @" 15159970 (30.12.2015), 15615115 (01.01.1970), 11224455, 55441123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}