# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bword\w*/<deleted>/gm;t' <<< "wording worder got worded. word!"