use strict;
my $str = 'wording worder got worded. word!';
my $regex = qr/\bword\w*/mp;
my $subst = '<deleted>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";