$re = '/(?=.*p)(?=.*o.*o)(?=.*u.*u)(?=.*l)(?=.*t.*t)(?=.*r)(?=.*y)(?=.*w)(?=.*i)(?=.*s.*s)(?=.*a)(?=.*n)(\b.{18}\b)/';
$str = 'pastilsturnouttowy
pastilstowyturnout
towyturnoutpastils
poultryoutwitsants';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;