const regex = /^[A-Za-z0-9_-]{1,20}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9_-]{1,20}$', '')
const str = `1234567890123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}