import Foundation
let pattern = #"\[([^\|]*)\|([^\]]*)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)