$re = '/\b(YOUU|MEIU) \d+ \d\b/';
$str = 'MEIU 810851 0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);