package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z0-9]+$`)
var str = `Please refer to reference MZ5051CLA
or
Attention for Mr Danshi, RE. 11123MTX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}