#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\s*No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test\s*"
Local $sString = "No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test asdfsdNo further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Testasdfasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")