using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test\s*";
string input = @"No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test asdfsdNo further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Testasdfasd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}