package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)^(?:\/[^\/\s]+)+Trash[^\/]*$`)
var str = `/a/b/.Trash
/a/b/.Trash+other words -> good
/a/b/.Trash -> good
/a/b/.blahTrash -> good
/a/.Trash -> good
/a/b/.Trash/c/d -> bad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}