re = /(?<=[^\/]>)[^>\P{IsBasicLatin}]*[\p{IsHiragana}\p{IsKatakana}\p{IsCJKUnifiedIdeographs}]+[^>\P{IsBasicLatin}]*(?=<\/)/i
str = '<tag3>Some text before 日本語 and some text after</tag3><tag>Before text 漢字</tag>.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end