$re = '/<articles:loop.+>(:?.|\n|\r)+?<\/articles:loop>/mi';
$str = '<articles:loop count="4">
<div>@Title@</div>
</articles:loop>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);