using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\n{2}|^)(?:(?:-|\d+\.) +.*\n?)+";
string input = @"- one
some text
- should not start a list
- should start
- should continue
5. should also
6. more
5. should also
6. more
7. more
8. sdfs
9. sdfsf
10. sdfdsf
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}