#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(?=.*?[1-9])[0-9\\,\\-]+$"
Local $sString = "90,91,90-200,90,900-9000"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)