const regex = /z:Assembly=\\"0\\">(?<fieldValue>(?:(?!<\/value>).)*)<\/value>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('z:Assembly=\\\\"0\\\\">(?<fieldValue>(?:(?!<\\\/value>).)*)<\\\/value>', 'g')
const str = `<value z:Id=\\"8\\" z:Type=\\"System.String\\" z:Assembly=\\"0\\">Status.</value>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);