re = /z:Assembly=\\"0\\">(?<fieldValue>(?:(?!<\/value>).)*)<\/value>/
str = '<value z:Id=\\"8\\" z:Type=\\"System.String\\" z:Assembly=\\"0\\">Status.</value>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result