import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\-+\\*=]+\\s*[\\-+\\*=]{1,2}\\s*('[^']+')\\s*\\&\\&";
final String string = "mydate == 'one day ago' && mydate > '2014-05-16 16:00:00'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}